Microsoft Office365 Disruption
Incident Report for Outreach
Resolved
Microsoft Office365 issues that affect mailbox connections in Outreach have been resolved. The root cause was a service disruption to Microsoft Office365. Over the next few days we will also be deploying an improvement to Outreach that will prevent turning off syncing and sending on mailboxes should another external disruption occur.
Posted Mar 27, 2017 - 09:14 PDT
Monitoring
Microsoft Office365 is currently experiencing issues and this may affect mailbox connections for Office365 users within the Outreach application.
Posted Mar 24, 2017 - 16:39 PDT