Issues sending emails in app2c
Incident Report for Outreach
Resolved
This issue has been resolved. Emails should no longer be stuck in "Sending Now".
Posted Nov 08, 2023 - 12:40 PST
Monitoring
We have implemented a fix where emails were stuck in "Send Now". We are seeing recovery and are continuing to monitor.
Posted Nov 08, 2023 - 12:21 PST
Investigating
We are currently investigating an issue where emails may get stuck in "Sending Now". We will provide updates as the become available.
Posted Nov 08, 2023 - 10:47 PST
This incident affected: App2c (Mailbox Sync).