Slower response times for imports and bulk actions
Incident Report for Outreach
Resolved
Import and bulk action slowness is now resolved.
Posted 5 months ago. Feb 19, 2019 - 12:12 PST
Investigating
We have noticed slower response times for imports and bulk actions. Engineering is investigating the issue.
Posted 5 months ago. Feb 19, 2019 - 09:29 PST