Intermittent Call Connection Failures
Incident Report for Outreach
Resolved
Any issues related to intermittent call connection failures has been resolved and you should now be able to make calls within Outreach. If you’re still experiencing issues, please contact support@outreach.io. Thank you for your patience.
Posted Oct 16, 2018 - 09:34 PDT
Investigating
We are currently working with our voice provider to investigate intermittent call connection failures.
Posted Oct 16, 2018 - 08:49 PDT