Update Regarding Outreach Everywhere Chrome Extension
Incident Report for Outreach
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 13, 2019 - 09:27 PDT
Identified
Today our Engineering team learned that the newest version of Chrome is incompatible with the Outreach Everywhere Chrome Extension. In Gmail, you will no longer be able to see Outreach in the compose window, which includes features such as “send later”, “bump”, and “add to sequence”. In Salesforce, you will not see the icons next to leads, contacts, and phone numbers to connect with prospects using the extension.

Outreach has filed a request with Google to help resolve these issues. We do not have an ETA for a fix at this time, but we will keep you updated with progress moving forward.
Posted 7 months ago. Mar 12, 2019 - 17:24 PDT