Call Quality and Connectivity
Incident Report for Outreach
Resolved
Our engineering team has resolved this issue and full functionality has been restored.
Posted 7 months ago. Mar 26, 2019 - 15:03 PDT
Investigating
Customers may be experiencing issues affecting call quality and connectivity. Our engineering team is currently investigating.
Posted 7 months ago. Mar 26, 2019 - 13:40 PDT