App2c - Some emails failing with "mailbox not recently synced" error
Incident Report for Outreach
Resolved
This issue is now resolved. Previously-failed mailing items with a "mailbox not recently synced" error will retry per your organization's configured retry settings.

If you previously disabled the "Require mailbox to be recently synced before sending" setting in your mailbox settings, you may now re-enabled that setting.
Posted Feb 19, 2024 - 12:29 PST
Identified
We've identified the root cause of the issue. This issue is only impacting users with the "Require mailbox to be recently synced before sending" setting enabled in the app2c production environment.

We're actively applying a fix to scale our resources, which will process sync requests and subsequently process emails relying on a recent sync occurring. Some users may begin to see previously-failed emails begin to process as our scaling operation progresses, which we expect to complete within the next 1-2 hours.

An update will be provided in the next 60 minutes.
Posted Feb 19, 2024 - 12:11 PST
Investigating
We're investigating reports of users encountering a "mailbox not recently synced" error when attempting to send emails. Impacted users will be unable to send email despite having mailboxes properly synced.

Workaround: Impacted users are able to navigate to Personal Settings > Mailbox > Advanced Settings > Send settings > and untick the "Require mailbox to be recently synced before sending". Once this issue is resolved, we will let you know when it is safe to re-enable this setting.

An update will be provided when a root cause has been identified.
Posted Feb 19, 2024 - 11:46 PST
This incident affected: App2c (Mailbox Sync).