App2c - Emails delayed in "Sending Now" state
Incident Report for Outreach
Resolved
This issue is resolved. We identified a configuration issue which added strain to mailing resources. We removed the source of the configuration issue and scaled up resources to process a backlog of mailing requests. By ~2:00 PM PT, all delayed mailing items were processed.
Posted Nov 16, 2023 - 14:02 PST
Identified
We have identified the root cause of the issue, and we're continuing to scale our resources to process the backlog of email requests in app2c.
Posted Nov 16, 2023 - 11:59 PST
Update
We have scaled up our email send resources. As a result, our telemetry is indicating an improvement in backlogged emails processing. Some users may continue to see delays until all backlogged emails are processed. We are continuing to investigate the root cause of the issue.
Posted Nov 16, 2023 - 10:35 PST
Update
We're continuing to investigate the root cause of the issue. In the meantime, we're exploring mitigation options to process all outstanding send requests. An update will be provided when a mitigation plan is in place.
Posted Nov 16, 2023 - 10:09 PST
Investigating
We are currently investigating reports of emails delayed in a "Sending Now" state. At this time, this is only impacting users hosted in the app2c environment. We will provide updates as the become available.
Posted Nov 16, 2023 - 09:32 PST
This incident affected: App2c (Mailbox Sync).