Loading Issues on Prospect Edit Page
Incident Report for Outreach
Resolved
The loading issues on the Prospect page have been resolved. The page is now fully functional. Please refresh your Outreach page if you experience any issues still.
Posted Jun 28, 2024 - 11:58 PDT
Monitoring
Our team has identified the issue, and is currently implementing a fix for the loading issues on the Prospect edit page. We are closely monitoring the situation to ensure stability.
Posted Jun 28, 2024 - 10:37 PDT
Update
Our team continues to investigate the loading issues on the Prospect page. We are making progress in diagnosing the problem.
Posted Jun 28, 2024 - 10:22 PDT
Investigating
We are currently investigating an issue causing the Prospect page to perpetually load for all users. Our team is actively working to identify the root cause. We will provide updates as soon as we have more information.
Posted Jun 28, 2024 - 10:02 PDT
This incident affected: Activity (App1a, App1b, App1c, App1d, App1e, App1f, App2a, App2b, App2c, App4a).