Issues placing calls and loading the Outreach platform
Incident Report for Outreach
Resolved
This issue is now resolved.

We identified connectivity issues between third-party internet providers and AWS between approximately 11:43 AM - 1:30 PM PT.

Outreach has resources hosted in AWS. Because of these connectivity issues, a subset of Outreach users in affected regions may have experienced a range of issues in the Outreach platform, including logging-in, loading pages, and/or placing calls.

We'll continue to monitor the situation. If you have any questions, please submit a ticket with Support at support.outreach.io.
Posted Mar 05, 2024 - 15:07 PST
Update
We're continuing to investigate the issue. Retries loading platform pages may be successful. An update will be provided when a root cause is identified, or as events warrant.
Posted Mar 05, 2024 - 13:54 PST
Investigating
We're investigating reports of increased latency when loading certain pages in the Outreach platform. Some users may encounter issues placing calls in the platform. Updates will provided as more information becomes known.
Posted Mar 05, 2024 - 13:19 PST
This incident affected: App2c (Application, Outreach Voice), App4a (Application, Outreach Voice), App2b (Application, Outreach Voice), App1a (Application, Outreach Voice), App1e (Application, Outreach Voice), App1f (Application, Outreach Voice), App2a (Application, Outreach Voice), App1b (Application, Outreach Voice), App1c (Application, Outreach Voice), and App1d (Application, Outreach Voice).