Chrome Extension Issues
Incident Report for Outreach
Resolved
Our engineering team has resolved the issue with version 1.3.35 of the Outreach Chrome extension. We will continue to monitor.
Posted Nov 25, 2019 - 17:41 PST
Investigating
Some users may be experiencing issues with the Outreach Chrome extension failing to load all page elements for drafts and when composing in Gmail. Our engineering team is currently investigating the issue.
Posted Nov 25, 2019 - 09:53 PST