Possible compatibility issues with Chrome/macOS
Incident Report for Outreach
Resolved
We've determined the Outreach platform is operating as expected with Google Chrome. Please connect with Outreach Support if you have any questions and we will be happy to assist you.
Posted Oct 16, 2023 - 16:44 PDT
Monitoring
We have been made aware of Outreach users using Mac experiencing possible issues including (but not necessarily limited to) using Outreach Voice via Google Chrome after an update to the latest Mac operating system, macOS Sonoma 14.

If you are using Outreach Voice via Google Chrome or any general issues using Chrome after an update to macOS, we recommend reaching out to your IT team to discuss which Chrome version and macOS version may be right for your organization.

Feel free to connect with our Support team via support.outreach.io and we will be happy to assist you.
Posted Oct 06, 2023 - 12:09 PDT